OWA 2010

Não é possível visualizar anexos no OWA 2003 quando enviados do OWA 2010

Fala pessoal, estou meio sumido! Alegre

Segue uma questão que encontrei em um cliente e foi um tanto difícil encontrar referências e KBs a respeito. Segue a descrição.

Cenário:

Exchange 2003 e 2010 em coexistência.

UsuárioA possui mailbox no Exchange 2010 e envia um e-mail com anexo utilizando OWA, para o UsuárioB que possui mailbox no Exchange 2003 e utiliza o OWA 2003.

O e-mail é recebido pelo UsuárioB no OWA, o ícone do anexo aparece, conforme figura abaixo:

image

Porém, quando você abre a mensagem, não há nenhum anexo:

image

 

Causa:

Depois de muito procurar (as vezes é complicado buscar KBs, você se expressa de uma forma e o título pode estar totalmente diferente Alegre ), encontrei um KB da Microsoft relatando a causa, no mínimo estranha.

This behavior is by design and is the result of enabling Silverlight on the Exchange Server 2010 Client Accss Server (CAS).

Se você habilita o Silverlight (da própria Microsoft Smiley de boca aberta) no servidor CAS, acontece isso nesse cenário.


Solução:

Method 1:

Log onto the CAS server with the appropriate Administrator permissions.
Disable silverlight from the Exchange Server 2010 Management Shell using the following cmdlet.

Set-OwaVirtualDirectory -Identity "Servername\Owa (Default Web Site)" -SilverLightEnabled $False

Where Servername is the name of the Client Access Server.  This action must be performed on each Client Access Server in the organization that is used.

Method 2:

Use a client that does not use the Silverlight (e.g., where Silverlight is not installed) to compose the e-mail message.

 

O KB foi retirado da base de dados de conhecimento da Microsoft, segue link original: http://support.microsoft.com/kb/2400041

 

Apliquei o método 1, foi tranquilo sem precisar reinicar nenhum serviço ou mesmo o aplicativo do OWA no IIS:

Set-OwaVirtualDirectory -Identity "Meu_CAS\Owa (Default Web Site)" -SilverLightEnabled $False

Olhem só o resultado:

image

image

 

Abs.

Tiago Ferreira

Share

Post to Twitter

Customizando visualmente o OWA no Exchange 2010 SP1

Visão Geral:
            Esse tutorial tem por objetivo, mostrar como modificar visualmente o site do OWA.
            Muitas empresas fazem esse tipo de modificação, para o OWA fica mais com a cara da empresa.
            Nesse tutorial vamos fazer modificações básicas.
            A estrutura de pastas mostrada nesse tutorial é do Exchange 2010 SP1 na versão do Exchange 2010 RTM a estrutura é diferente.
Procedimento:

1- Vá em C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\Owa\14.1.218.13\themes, com o SP1 do Exchange 2010 você vai ter uma lista grande de temas, aqui vamos usa somente o “base”. Acesse a pasta “base” vamos editar o arquivo “csssprites” (LEMBRANDO DE FAZER O BACKUP ANTES DE EDITAR) o arquivo vai estar como na imagem abaixo.

Aqui vou adicionar a imagem da organização, depois da edição vai ficar como na imagem abaixo.

OBS: Lembrando que sou analista de redes e não designer gráfico.
Depois de editar a imagem o resultado fica conforme imagem abaixo.
2-  Vá em C:\Program Files\Microsoft\Exchange Server \V14\ ClientAccess \Owa \14.1.218.13 \themes\resources, vamos editar o arquivo “lgntopl” (LEMBRANDO DE FAZER O BACKUP ANTES DE EDITAR) o arquivo vai estar como na imagem abaixo.
Depois de editar o arquivo, vai ficar como na imagem abaixo.
Na imagem abaixo segue o resultado
Qualquer dúvida = ewerton_stabile@yahoo.com.br
Site= www.msitpro.com.br Blog= ewerton-stabile.blogspot.com
Share

Post to Twitter